Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7588 closed bug (duplicate)

Div where resizable disabled becomes transparent

Reported by: [email protected] Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.resizable Version: 1.8
Keywords: Cc:
Blocked by: Blocking:

Description

If disabled is set to true in initialization, when it is set to false from user action, then set to true again, the div becomes transparent. Need flexibility in code to decide what the div appearance should be. Transparent div isn't always the desired behavior. It might be necessary to show same appearance as when resizable allowed.

<script type='text/javascript'>

$(document).ready(function(){

      $(function() {
         $("#slide").resizable({ disabled: true });
      });  

});

$(document).ready(function(){
      $("#trees").toggle(function(){
            //Open menu      
            $("#slide").stop().animate({ left: "+=208" }, 1200);
            $("#viewup").css("visibility","hidden");
            $("#slide").resizable({ disabled: false });
      }, function(){
            //Close menu
            $("#slide").css("width","236");
            $("#slide").stop().animate({ left: "-=208" }, 1200);
            $("#viewup").css("visibility","visible");
            $("#slide").resizable({ disabled: true });
      }); 

});

</script>

The code under Close menu causes the div appearance to become transparent. If instead of

            $("#slide").resizable({ disabled: true });

I do

            $("#slide").resizable( "option", "disabled", true );

then resizing isn't deactivated at all.

Change History (2)

comment:1 Changed 10 years ago by rdworth

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by rdworth

Duplicate of #5973.

Note: See TracTickets for help on using tickets.