Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#5973 closed bug (fixed)

Resizable: disabled should not have the ui-state-disabled class or aria attribute aria-disabled

Reported by: julienw Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.resizable Version: 1.8.4
Keywords: Cc:
Blocked by: Blocking:

Description

When using the "disable" operation (with resizable), we get the ui-state-disabled class which is not desirable as the widget is not disabled as a whole.

Change History (11)

comment:1 Changed 7 years ago by rdworth

  • Summary changed from disable operation shouldn't put ui-state-disabled class neither aria attribute aria-disabled to Resizable: disabled should not have the ui-state-disabled class or aria attribute aria-disabled

Note the similarity to #5501 - sortable: disabled should not have the ui-state-disabled class

comment:2 Changed 6 years ago by rdworth

This causes an issue with a nested resizable inside a disabled resizable. See http://jsfiddle.net/rdworth/vaD8v/ for a repro including a workaround. From http://forum.jquery.com/topic/trouble-with-nested-resizables

comment:3 Changed 6 years ago by rdworth

#7588 is a duplicate of this ticket.

comment:4 Changed 4 years ago by scottgonzalez

  • Milestone changed from TBD to 2.0.0

comment:5 Changed 4 years ago by tj.vantoll

  • Status changed from new to open

comment:6 Changed 4 years ago by mikesherov

related to #5974 and #6039

comment:7 Changed 4 years ago by Mike Sherov

  • Resolution set to fixed
  • Status changed from open to closed

Widget: Stop setting ui-state-disabled and aria by default on setting disabled option. Fixes #5973 - Resizable: disabled should not have the ui-state-disabled class or aria attribute aria-disabled Fixes #5974 - Draggable: disabled should not have the ui-state-disabled class or aria attribute aria-disabled Fixes #6039 - Droppable : disabled should not have ui-state-disabled

Changeset: 4d67f4f34908a50ef88f95df4103ee001b777e45

comment:8 Changed 4 years ago by mikesherov

  • Milestone changed from 2.0.0 to 1.10.2

comment:9 Changed 4 years ago by scottgonzalez

  • Milestone changed from 1.10.2 to 1.11.0
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reverted to keep this out of a patch release.

comment:10 Changed 4 years ago by Scott González

  • Resolution set to fixed
  • Status changed from reopened to closed

Widget: Stop setting ui-state-disabled and aria by default on setting disabled option. Fixes #5973 - Resizable: disabled should not have the ui-state-disabled class or aria attribute aria-disabled Fixes #5974 - Draggable: disabled should not have the ui-state-disabled class or aria attribute aria-disabled Fixes #6039 - Droppable: disabled should not have ui-state-disabled

This reverts commit 23771d38ba9d2663f6db0243c8e992dc7ff6844a.

Changeset: 44d07173db32b498e5f83f60db290ff1463daee3

comment:11 Changed 4 years ago by mikesherov

#9194 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.