Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#7612 closed bug (fixed)

Calling stop(true, true) on an effect will change absolute positioning from the affected element

Reported by: MetalArend Owned by:
Priority: minor Milestone: 1.8.23
Component: ui.effects.core Version: 1.8.23
Keywords: Cc:
Blocked by: Blocking:

Description

When stopping an effect with stop(true, true), one would would expect the effect going to the end of the values, and keeping everything from the beginning, only changing some values to their end value. But the positioning from the box changes also. It goes even further than this example; if I declare a absolute positioning, with a bottom-value, the stop(true, true) part will actually change my bottom positioning to a top positioning!

jQuery: 1.6.2 jQuery UI: 1.8.14 Browser: FFX 5.0

<!doctype html> <html> <head>

<title>bug</title> <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script> <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.14/jquery-ui.min.js"></script> <style>

a { color: inherit; } .bug_box { margin: 5px; float: left; border: 5px double #eeeeff; } .bug_playground { height: 300px; width: 300px; background: #aaaacc; } .bug_problem { height: 150px; width: 150px; background: #ff0000; }

</style>

</head> <body>

<div class="bug_box">

<div style="position: relative;" class="bug_playground">

<div id="bug02" style="position: absolute; top: 150px; left: 150px; height: 150px; width: 150px;" class="bug_problem">BUG 02</div>

</div> <a href="#" onclick="$('#bug02').stop(true, true).toggle('blind', 'slow');">Show / Hide</a>

</div>

</body> </html>

Change History (5)

comment:2 Changed 8 years ago by Corey Frang

This could be a dupe of http://bugs.jqueryui.com/ticket/7123 - Will investigate further soon

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:4 Changed 7 years ago by mikesherov

Resolution: fixed
Status: newclosed
Version: 1.8.141.8.23

This was fixed by the core animation rewrite.

comment:5 Changed 7 years ago by Scott González

Milestone: 1.10.01.8.23
Note: See TracTickets for help on using tickets.