Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7674 closed bug (fixed)

Autocomplete doesn't work with textareas

Reported by: meh-cfl Owned by:
Priority: minor Milestone: git
Component: ui.autocomplete Version: git (not yet released)
Keywords: Cc:
Blocked by: Blocking:

Description

Attaching the autocomplete plugin to a textarea doesn't show the autocomplete search menu when typing text.

Steps to reproduce:

  1. Create a text area and attach the autocomplete plugin to it.
  2. Type some text into the text box which appears in the autocomplete source.

Expected: The autocomplete menu should be displayed.

Actual: The autocomplete menu isn't displayed.

Notes: This is a regression over version 1.8.14. I will also commit a failing test for this shortly.

Change History (7)

comment:1 Changed 8 years ago by meh-cfl

Failing test added as part of https://github.com/jquery/jquery-ui/pull/443.

comment:2 Changed 8 years ago by meh-cfl

I've had another go. Failing test case added in https://github.com/jquery/jquery-ui/pull/444.

comment:3 Changed 8 years ago by Scott González

Resolution: worksforme
Status: newclosed

Works for me: http://jsbin.com/otavey/edit#javascript,html

Please provide a page showing the problem.

comment:4 Changed 8 years ago by Scott González

Resolution: worksforme
Status: closedreopened

Sorry, didn't see that this was filed against master, since you referenced a regression over a version 2 releases ago.

comment:5 Changed 8 years ago by rdworth

This regression was introduced by commit 5095871 with the addition of line 42:

		this.valueMethod = this.element[ this.element.is( "input" ) ? "val" : "text" ];

comment:6 Changed 8 years ago by Scott González

Resolution: fixed
Status: reopenedclosed

Autocomplete: Fixed setting of valueMethod for textareas. Fixes #7674 - Autocomplete doesn't work with textareas.

Changeset: c5ba0535cf8fad222bf54249fb74339faafa9310

comment:7 Changed 8 years ago by Scott González

Milestone: 1.9git
Note: See TracTickets for help on using tickets.