Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7682 closed enhancement (duplicate)

i can't resize the dialog when there is an iframe inside the dialog

Reported by: lining041038 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.15
Keywords: Cc:
Blocked by: Blocking:

Description

i can't resize the dialog when there is an iframe inside the dialog and when my cursor is in the iframe, i think it is not a bug ,but i usually use iframe inside when i want to link a website outside or my other pages.

Change History (3)

comment:1 Changed 8 years ago by rdworth

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by rdworth

Duplicate of #7650.

comment:3 Changed 8 years ago by kruncher

@lining041038

Here is a workaround:

$("#modalDiv")
    .dialog({
        modal    : true,
        autoOpen : false,
        height   : 400,
        width    : 400,
        draggable: true,
        resizable: true,
        title    : 'Loading...'
    })
    .bind('dialogdragstart dialogresizestart', function() {
        var overlay = $(this).find('.hidden-dialog-overlay');
        if (!overlay.length) {
            overlay = $('<div class="hidden-dialog-overlay" style="position:absolute;top:0;left:0;right:0;bottom:0;z-order:100000;"></div>');
            overlay.appendTo(this);
        }
        else
            overlay.show();
    })
    .bind('dialogdragstop dialogresizestop', function() {
        $(this).find('.hidden-dialog-overlay').hide();
    });
Note: See TracTickets for help on using tickets.