Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#7650 closed bug (fixed)

Dialog cannot be dragged properly with IFRAME

Reported by: kruncher Owned by:
Priority: minor Milestone: 1.10.1
Component: ui.dialog Version: 1.8.15
Keywords: Cc:
Blocked by: Blocking:

Description

Dialog dragging is glitchy when IFRAME is contained within content area. Dialog movement stops when mouse pointer overlaps IFRAME. Same issue occurs when resizing dialog.

The following fix works for me, but I suspect something better could be added into the dialog script.

var __overlay_fix_start = function() {
	var overlay = $(this).find('.hidden-dialog-overlay');
	if (!overlay.length) {
		overlay = $('<div class="hidden-dialog-overlay" style="position:absolute;top:0;left:0;right:0;bottom:0;z-order:100000;"></div>');
		overlay.appendTo(this);
	}
	else
		overlay.show();
};
var __overlay_fix_stop = function() {
	$(this).find('.hidden-dialog-overlay').hide();
};

// Cover dialog content with overlay during resizing / moving
// to avoid unusual results.
options.resizeStart = (options.dragStart = __overlay_fix_start);
// Hide transparent overlay once dragging or resizing has stopped
options.resizeStop = (options.dragStop = __overlay_fix_stop);

Change History (7)

comment:1 Changed 8 years ago by Scott González

Status: newopen

We can turn on iframeFix for draggable, but resizable doesn't have an option yet. After the interactions rewrite this will automatically happen.

comment:2 Changed 8 years ago by rdworth

#7682 is a duplicate of this ticket.

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:4 Changed 7 years ago by Scott González

Milestone: 1.10.02.0.0

comment:5 Changed 7 years ago by Jörn Zaefferer

Scott on IRC: "We can build an iframe fix inside dialog for now. Alternatively, we can implement iframe fix in resizable. And that wouldn't require any hacks."

Last edited 7 years ago by Jörn Zaefferer (previous) (diff)

comment:6 Changed 7 years ago by Scott González

Resolution: fixed
Status: openclosed

Dailog: Cover iframes during drag and resize. Fixes #7650 - Dialog cannot be dragged properly with IFRAME.

Changeset: a7353e7c9ba18e017813195c885115338800e13d

comment:7 Changed 7 years ago by Scott González

Milestone: 2.0.01.10.1
Note: See TracTickets for help on using tickets.