Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7723 closed bug (duplicate)

jquery ui button does not support implicit labels

Reported by: studgeek Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.button Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

The jquery ui button does not support implicit labels as described at http://www.w3.org/TR/html4/interact/forms.html#h-17.9.1 like the following.

<label>
<input type="checkbox" />
</label>

See a http://jsfiddle.net/studgeek/8xpYs/ for a live example.

I've looked at fixing it. Modifying it to check for a containing label when defining its buttonElement is straightforward, but there are other parts of the implementation that run into recursion problems. I've played with detaching the input element or moving it outside the label, but worry those approaches may confuse developers. Is there a standard pattern used elsewhere in jQuery UI that would apply here?

d

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by Scott González

Duplicate of #6063.

Note: See TracTickets for help on using tickets.