Opened 6 years ago

Closed 2 years ago

#7772 closed bug (duplicate)

Draggable: when css 'right' is set, element resizes on drag

Reported by: dmitry_f Owned by:
Priority: minor Milestone:
Component: ui.draggable Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

Here's demo of bug: http://jsfiddle.net/6tgec/1/ If we set 'right:0' for element, then element resizes on drag. That's incorrect.

Change History (8)

comment:1 Changed 5 years ago by Scott González

Milestone: 1.9.02.0.0

comment:2 Changed 5 years ago by mikesherov

Status: newopen
Summary: Draggable element 'right:0' bugDraggable: when css 'right:0' is set, element resizes on drag

Confirmed on latest: http://jsfiddle.net/BW3NW/

comment:3 Changed 5 years ago by tj.vantoll

Summary: Draggable: when css 'right:0' is set, element resizes on dragDraggable: when css 'right' is set, element resizes on drag

The value of the right rule doesn't matter. Also resizable has similar issues http://jsfiddle.net/tj_vantoll/3Rzsu/.

comment:4 Changed 5 years ago by tj.vantoll

The resizable issue is being handled in #9033.

comment:5 Changed 3 years ago by Uri Gilad

Resolution: fixed
Status: openclosed

Draggable: Set explicit width/height instead of right/bottom css.

Fixes #7772

Changeset: 8eca7b8f45885d20c13f1bf64cad8bee5fc1d5c5

comment:6 Changed 3 years ago by mikesherov

Milestone: 2.0.01.11.2

comment:7 Changed 2 years ago by Scott González

Milestone: 1.11.2
Resolution: fixed
Status: closedreopened

comment:8 Changed 2 years ago by Scott González

Resolution: duplicate
Status: reopenedclosed

Duplicate of #3011.

Note: See TracTickets for help on using tickets.