Opened 8 years ago

Closed 7 years ago

#7773 closed bug (fixed)

Dialog: If titlebar changes height during resize, button pane positioning changes

Reported by: raphinesse Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

OS: Windows Vista Business x86 SP2
Tested Browsers: FF 7.0.1, Chrome 14.0.835.202, IE 9.0.8112.16421

To reproduce:

  1. Visit http://jqueryui.com/demos/dialog/#modal-message
  2. Execute following code in your Browser's console:
    $('#dialog-message').dialog('option', 'title', 'Download completely messed up due to connectivity issues!')
  3. Change the dialog's width using the resizeable feature so that the number of lines in .ui-dialog-titlebar changes

Expected result: .ui-dialog-buttonpane stays at the bottom of the dialog

Experienced result: .ui-dialog-buttonpane moves up and down and eventually out of view if you reduce the dialogs width by a sufficient amount

Change History (7)

comment:1 Changed 8 years ago by Scott González

Status: newopen
Summary: Changing line count in .ui-dialog-titlebar breaks dialog layoutDialog: If titlebar changes height during resize, button pane positioning changes

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:3 Changed 7 years ago by Jörn Zaefferer

Fot the buttonpane to stay fully visible, either the height of the dialog needs to grow or the content area to shrink. Currently the additional height used by the titlebar is "taken" from the buttonpane instead. Since the content will scroll-overflow eventually anyway, reducing the height of the content seems like the right apporach to me.

comment:4 Changed 7 years ago by Scott González

Any objections to just forcing the title to always be a single line using white-space: nowrap?

comment:5 Changed 7 years ago by Scott González

We could actually use white-space: nowrap; width: 90%; overflow: hidden; text-overflow: ellipsis; That should get us a reasonable display in all browsers.

comment:6 Changed 7 years ago by Jörn Zaefferer

comment:7 Changed 7 years ago by Jörn Zaefferer

Resolution: fixed
Status: openclosed

Dialog: Restrict title to a single line. Fixes #7773 - Dialog: If titlebar changes height during resize, button pane positioning changes.

Changeset: bdb0fbe993ab4c716f3cbc6f2c08072bf512115f

Note: See TracTickets for help on using tickets.