Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7787 closed bug (duplicate)

Clicking outside of results list prevents the same query from running a second time

Reported by: drbawb Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

Version(s) affected: The test-case targets jQuery 1.6.4 and jQuery-UI 1.8.16 This bug also affects: jQuery-UI 1.8.9 and jQuery 1.4.4

Browser(s) affected: Firefox (7.0.1), Chrome (14.0.835.202 m), IE 9 (9.0.8112.16421)

OS(es) affected: Windows 7(Firefox, Chrome, IE 9), Ubuntu 10.10 (Firefox 7.0.1 ONLY)

Steps to reproduce:

1. Type in a query, for example "ja", this should populate your drop-down with "Java" and "JavaScript"
2. Click anywhere OUTSIDE the results box to dismiss the results box.
3. Highlight "ja" in the textbox. (Either using the mouse, or using your browser's Select All functionality (Ctrl or Cmd + A)
4. Hit backspace to delete the highlighted "ja"
5. Type "ja" 
6. List should not repopulate.

If you actually backspace, without highlight, the drop down menu repopulates, as I would anticipate. Also if you type ANY OTHER QUERY aside from the original input, the results box will display. (To reproduce, substitute a different query in for step 5.)

Test Case: http://jsfiddle.net/drbawb/wRmHu/1/

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by Scott González

Duplicate of #7434.

Note: See TracTickets for help on using tickets.