Opened 6 years ago

Closed 3 years ago

Last modified 3 years ago

#7434 closed bug (fixed)

Autocomplete: Selected Text Trigger Usability Issue

Reported by: Gbiggs Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.autocomplete Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

When you type a letter in an autocomplete box, the list pulls up. Click outside of the list (let's say a user hastily clicks and "misses" the list). The list box closes, when you select the letter and retype it - the list doesn't show up.

This doesn't happen if you type a different letter. It may be more a minor usability error, "Where did the list go? I retyped the letter. I know there are results!"

Change History (14)

comment:1 Changed 6 years ago by cgack

try it yourself at jsbin. http://jsbin.com/abeton/

comment:3 Changed 6 years ago by Scott González

#7787 is a duplicate of this ticket.

comment:4 Changed 5 years ago by Jörn Zaefferer

Status: newopen

The actual commit is this: https://github.com/cgack/jquery-ui/commit/d003c58489c83bfa41ad090a2071b420368287a9

While I can see the issue as valid, I don't think this approach is acceptable. We specifically don't want any key event to trigger a search, e.g. pressing modifier keys don't modify the input, so shouldn't trigger a search.

comment:6 Changed 5 years ago by Scott González

Milestone: 1.9.01.10.0

comment:7 Changed 5 years ago by mikesherov

Summary: Autocomplete - Selected Text TriggerAutocomplete: Selected Text Trigger Usability Issue

comment:8 Changed 5 years ago by tj.vantoll

Milestone: 1.10.0none

comment:9 Changed 4 years ago by Scott González

#9329 is a duplicate of this ticket.

comment:10 Changed 4 years ago by tj.vantoll

#9740 is a duplicate of this ticket.

comment:11 Changed 3 years ago by Scott González

#9969 is a duplicate of this ticket.

comment:12 Changed 3 years ago by tj.vantoll

PR: https://github.com/jquery/jquery-ui/pull/1238

This basically takes cgack's approach and accounts for modifier keys.

comment:13 Changed 3 years ago by TJ VanToll

Resolution: fixed
Status: openclosed

Autocomplete: Search if the user retypes the same value

Fixes #7434 Closes gh-1238

Changeset: 48001a8c46adc5d1d6c1726cecbe6453946e96e0

comment:14 Changed 3 years ago by tj.vantoll

Milestone: none1.11.0
Note: See TracTickets for help on using tickets.