Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7832 closed bug (duplicate)

Opera browser using wrong overflow-property in accordion

Reported by: pv.burnabit Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.accordion Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

Opera sets the css property overflow to visible instead of auto after opening a new slide.
Error occurs in jquery.ui.accordion.js in line 544:

var overflow = options.toShow.css( "overflow" ),
               percentDone = 0,
               showProps = {},
               hideProps = {},
               fxAttrs = [ "height", "paddingTop", "paddingBottom" ],
               originalWidth;

var overflow equals "auto" in all browsers except Opera. Wrong css property is then applied in line 596.


Reproducing the problem:


Dirty workaround:
Set overflow to "auto" in line 596.


Software setup:

  • MacOS 10.6.8
  • Opera Browser 11.51 and 11.52
  • jQuery 1.6.4
  • jQuery UI 1.8.16

Change History (2)

comment:1 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Scott González

Duplicate of #6971.

Note: See TracTickets for help on using tickets.