Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#6971 closed bug (fixed)

Accordion animation bug in Opera 11.01 with jQuery 1.4.3+

Reported by: victorq10 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.accordion Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

http://jqueryui.com/demos/accordion/fillspace.html

this example work when

  • jquery version is 1.4.2 (tested with jquery-ui 1.8.2 and 1.8.9)
  • or animation is false with jquery 1.4.4 jquery-ui 1.8.9

may be some problem in annimation combinated with jquery 1.4.4

all work in: in Chrome 8.0.552.224 and IE 8.0

Change History (7)

comment:1 Changed 8 years ago by Scott González

Status: newopen

comment:2 Changed 8 years ago by Scott González

Summary: Accordion not work in Opera 11.01 browser with jquery-1.4.4 when animation is on.Accordion animation bug in Opera 11.01 with jQuery 1.4.3+

comment:3 Changed 8 years ago by mohdyusuf

I can confirm this animation bug is also seen with:

  • firefox 4/5
  • chrome 12 beta
  • jquery 1.4.3+ (tested till 1.6.1) with jqueryui 1.8.10

Note: IE9 works fine

comment:4 Changed 8 years ago by lorak110786

Tested with JQ 1.4.4 UI 1.8.13

FF 3.6.17 works fine

FF 4.0.1 works fine (subjective: animation isn't smooth)

CHROME 12 works fine

IE 8,9 works fine

Opera 11.11 animation bug

comment:5 Changed 7 years ago by lorak110786

There's no more error in Opera 11.6.

Last edited 7 years ago by lorak110786 (previous) (diff)

comment:6 Changed 7 years ago by Scott González

Resolution: fixed
Status: openclosed

Accordion: Reset overflowX and overflowY after animations to fix overflow in Opera <11.6. Fixes #6971 - Accordion animation bug in Opera 11.01 with jQuery 1.4.3+.

Changeset: ecddf469d7924d88d72e57a4806996fc50fa50ae

comment:7 Changed 7 years ago by Scott González

#7832 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.