Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7867 closed bug (duplicate)

jQuery UI Tabs - Click Event

Reported by: jimmyheaddon Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.tabs Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

I'm not sure if this is a core jQuery issue or one of jQuery UI Tabs, but in IE8 with jQuery 1.7 and jQuery 1.8.16 if you try to bind to the click event of a tab as follows:

$('#jQueryTabs ul li a').live('click', function () {});

Nothing will happen when you click on any of the tabs. However, if you change the syntax to be as follows it will work as expected:

$('#jQueryTabs ul li a').click(function () {});

I was under the impression that the .live() and .on() events would cover all of these scenarios?

Thanks!

Change History (2)

comment:1 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Scott González

Duplicate of #6765.

Note: See TracTickets for help on using tickets.