Opened 7 years ago

Closed 7 years ago

#7868 closed feature (fixed)

Tabs: Provide tab and panel details in create event

Reported by: CTAPbIuMABP Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.tabs Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

Tabs create event has empty ui object instead of object that holds information about current tab like in select event

http://jsfiddle.net/CTAPbIu_MABP/DytGX/3/

Change History (6)

comment:1 Changed 7 years ago by Scott González

Resolution: invalid
Status: newclosed

This is not a bug. No widgets provide information in the create event.

comment:2 Changed 7 years ago by CTAPbIuMABP

but how can i know what tab was selected if it was restored from cookie or document.location.hash

comment:3 Changed 7 years ago by rdworth

$(this).tabs("option", "selected")

comment:4 Changed 7 years ago by Scott González

Resolution: invalid
Status: closedreopened
Summary: Tabs create event has empty ui objectTabs: Provide tab and panel details in create event
Type: bugfeature

comment:5 Changed 7 years ago by CTAPbIuMABP

thanks :)

comment:6 Changed 7 years ago by Scott González

Resolution: fixed
Status: reopenedclosed

Tabs: Pass tab and panel in create event. Fixes #7868 - Tabs: Provide tab and panel details in create event.

Changeset: 6800e1a2f97a7d8aaf20d065aa2ce517528e5068

Note: See TracTickets for help on using tickets.