Opened 8 years ago

Closed 3 years ago

#7904 closed bug (wontfix)

Sortable: Cursor is not reset after sorting in IE9

Reported by: peter.morlion Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

I'm not entirely sure if this is a bug in jQuery UI or in Internet Explorer, but this is the issue:

If you want to indicate to a user that something is sortable, the cursor option isn't sufficient. This is only active when sorting. So you could indicate something is sortable by adding cursor: move; to your css. This works in Chrome (and probably other browsers), but not in IE.

In Internet Explorer, it works as long as you don't sort. After you've sorted, the cursor won't change back to auto, unless you click somewhere.

I've put this in a JsFiddle. In the JsFiddle, I've used jQuery 1.4.4 because that's what we use, but it's the same with jQuery 1.7. The jQuery UI version is 1.8.7.

Change History (8)

comment:1 Changed 8 years ago by Bung

I can confirm this bug in IE9. I happen to be using compatibility view as well. I have tried adding a click() call, see below, in both the stop and update event, all it manages to do is reset the cursor, but then a second click is required to get things sortable again.

stop: function(e,ui){ $('handleSelector', ui.item).click(); },

As well as the same click() line in the update event, also tried clicking on parent()s.

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 7 years ago by petersendidit

Status: newopen
Summary: Cursor is not reset after sorting in IESortable: Cursor is not reset after sorting in IE

comment:4 Changed 7 years ago by tj.vantoll

#8347 is a duplicate of this ticket.

comment:5 Changed 7 years ago by tj.vantoll

http://jsfiddle.net/jeremyfrank/7VSn3/ is another test case for this issue (from #8347).

comment:6 Changed 7 years ago by tj.vantoll

Summary: Sortable: Cursor is not reset after sorting in IESortable: Cursor is not reset after sorting in IE9

The test cases work fine in IE8 and IE10. This appears to be limited to IE9.

comment:7 Changed 7 years ago by tj.vantoll

Here's a minified test case showing the issue still occurs in master - http://jsfiddle.net/tj_vantoll/R8Fwd/. Interestingly the issue is not present using the cursor option (i.e. $( '#sortable').sortable({ cursor: 'move' }) but it is if cursor: move; is defined in CSS.

comment:8 Changed 3 years ago by Scott González

Resolution: wontfix
Status: openclosed

We no longer support IE9.

Note: See TracTickets for help on using tickets.