Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#7913 closed bug (worksforme)

Draggable: Containment can be broken when scrolling while dragging

Reported by: bugsBuggy Owned by:
Priority: minor Milestone: 1.10.3
Component: ui.draggable Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by mikesherov)

[22:53] <dogarrhea2> i just installed chrome 5 minutes ago
[22:53] <dogarrhea2> change your browser size to something where a scrollbar on the right shows up.
[22:53] <dogarrhea2> drag the element that is "contained in parent etc." towards the part of the screen which will cause a scroll.
[22:55] <dogarrhea2> for those of you trying to follow along, it's at http://jqueryui.com/demos/draggable/constrain-movement.html for the "contained in parent" draggable
[22:55] <dogarrhea2> you can actually drag it outside if your window is resized. 
[22:55] <Eviltwin> Not sure anyone is trying to follow along :P
[22:55] <dogarrhea2> were you able to replicate Eviltwin?
[22:55] <Eviltwin> Yeah, I didn't realize you needed to make the window scroll
[22:55] <Eviltwin> Missed that part
[22:57] <Eviltwin> I'm guessing this is to account for a scrolling parent element
[22:57] == mariuscc [~mariuscc@79.112.120.98] has joined #jquery
[22:58] == VeggieMeat [~veggiemea@64.19.101.243] has joined #jquery
[22:58] <Eviltwin> Well report it to jQuery UI devs

Change History (7)

comment:1 Changed 8 years ago by bugsBuggy

Explanation of irc log:

Dragging a draggable element which has containment is totally broken when the entire page scrolls while the dragging is in effect. This can actually be seen in the link provided above (to the actual demo page where it is broken)at http://jqueryui.com/demos/draggable/constrain-movement.html

Last edited 8 years ago by bugsBuggy (previous) (diff)

comment:2 Changed 7 years ago by Scott González

#8412 is a duplicate of this ticket.

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:4 Changed 7 years ago by mikesherov

Description: modified (diff)

comment:5 Changed 7 years ago by mikesherov

Status: newopen
Summary: draggable containment scrollbarDraggable: Containment can be broken when scrolling while dragging

Confirmed as described: http://jqueryui.com/draggable/#constrain-movement

  1. Click and drag the "I'm contained within my parent" element to the bottom of its parent.
  2. While still dragging the element, scroll the iframe down.
  3. move the mouse slightly while still dragging.
  4. observe the element jumping out of the containment.

It may take a few times to get it... it's a quite fickle set of repro steps.

comment:6 Changed 5 years ago by mikesherov

Milestone: 2.0.0none
Resolution: worksforme
Status: openclosed

This works and was fixed in 1.10.3

comment:7 Changed 5 years ago by Scott González

Milestone: none1.10.3
Note: See TracTickets for help on using tickets.