Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#7922 closed bug (fixed)

Slider with range doesn't work if values are not set

Reported by: Mamen Owned by: petersendidit
Priority: minor Milestone: 1.9.1
Component: ui.slider Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

If a slider object is created with the options {range: true, values: null}, only one handle is present. If option "values" are specified two handles appears like expected. It doesn't support values = null which is the default option.

I'm not able to create ANY visible sliders on jsFiddle, but the code should be easy:

$("#selector").slider({range: true});

According to Coding standards: Plugins must work regardless of what options are passed to init. All options are truly optional and may be changed at any time.

Change History (8)

comment:1 Changed 8 years ago by rdworth

Version: 1.8.161.8.13

comment:2 Changed 8 years ago by rdworth

Caused by #7259

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.01.11.0

comment:4 Changed 7 years ago by tj.vantoll

Status: newopen

I can verify that this is still an issue in 1.9 - http://jsfiddle.net/tj_vantoll/7SgsX/. Here's an example showing not passing in values working with 1.7.3 - http://jsfiddle.net/tj_vantoll/9CSxm/.

comment:5 Changed 7 years ago by petersendidit

Owner: set to petersendidit
Status: openassigned

comment:6 Changed 7 years ago by petersendidit

comment:7 Changed 7 years ago by David Petersen

Resolution: fixed
Status: assignedclosed

Slider: Count the handles after setting up a range. Fixes #7922 - Slider with range doesn't work if values are not set.

Changeset: dda1925d0f8d19b4baffa20259674dcef85e8bab

comment:8 Changed 7 years ago by Scott González

Milestone: 1.11.01.9.1
Note: See TracTickets for help on using tickets.