Opened 8 years ago

Closed 7 years ago

#7935 closed bug (duplicate)

draggable() + scroll in chrome

Reported by: Samurai.by Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.draggable Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

If click in scroll bar, div adhere in cursor and not drop. (in google chrome)

<script type="text/javascript">
    $(function () { 
            $('#draggableD').draggable();
            });
</script>

<div id="draggableD"> Header <div id="test" style="overflow-y:scroll; height:200px; width:100px;"> text
text text text text
text text text text
text text text text
text text text text
</div> </div>

Change History (4)

comment:1 Changed 8 years ago by tj.vantoll

The same behavior occurs in Safari 5.1.2 and Opera 11.60 - http://jsfiddle.net/mKHX7/. Works fine in Firefox 9 and IE 7/8/9.

comment:2 Changed 8 years ago by tj.vantoll

This is occurring because the mouseup event does not fire on scrollbars in Chrome / Safari / Opera - http://jsfiddle.net/NtEkr/. The draggable plugin uses the event to stop the dragging, and since it's never fired this issue occurs.

There's a more thorough explanation in jQuery bug #8184 which was closed as invalid. There's also links to open bugs in Chrome and WebKit here - http://stackoverflow.com/questions/4145402/mouseup-bug-in-all-browsers-except-firefox.

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:4 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #6925.

Note: See TracTickets for help on using tickets.