Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8009 closed bug (duplicate)

Datepicker: getDate returns the incorrect date when typing invalid value

Reported by: fingermark Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description

I'm using the datepicker demo. When I input "09012013" into the input field (and then click on some whitespace to close the calendar window), it sets the date to today, according to getDate. Shouldn't getDate return Sep 12 2013?

http://s16.postimage.org/w7jcti4f7/sshot.png.

Change History (5)

comment:1 Changed 10 years ago by fingermark

Or at least keep it null.

comment:2 Changed 10 years ago by Scott González

Component: ui.coreui.datepicker
Summary: getDate returns the incorrect date when Inputting date w/o slashesDatepicker: getDate returns the incorrect date when typing invalid value

comment:3 Changed 10 years ago by Scott González

Milestone: 1.9.01.11.0

comment:4 Changed 10 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #7786.

comment:5 Changed 10 years ago by mikesherov

#8159 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.