Opened 8 years ago

Last modified 7 months ago

#8159 open feature

datepicker('setDate' null) should not set today active

Reported by: raphinesse Owned by:
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Description

To overcome the issue that today never appears as selected or hovered I reordered the rules for ui-state-active and ui-state-hover to be more important than ui-state-highlight. However this revealed that, as of now, it is not possible to have no active date in a Datepicker instance. Calling datepicker('setDate' null) sets today as active.

Change History (8)

comment:1 Changed 7 years ago by Scott González

Type: enhancementfeature

comment:2 Changed 7 years ago by Benjamin

Confirmed, datepicker('setDate', null) only resets the <input>, but leaves a date highlighted on the datepicker. That's definitely a problem when using an always-visible datepicker in a web application, without necessarily having a related <input>. There's currently no way to remove the selection.

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.01.11.0

comment:4 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #8009.

comment:5 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: closedreopened

comment:6 Changed 7 years ago by mikesherov

Status: reopenedopen

comment:7 Changed 5 years ago by Scott González

Milestone: 1.11.0none

comment:8 Changed 7 months ago by Stephen Hendricks

so after 7 years we are nowhere with this?

Note: See TracTickets for help on using tickets.