Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#8033 closed bug (notabug)

Dialog has extra buttons when you add functions to Array.prototype.

Reported by: joshmouch Owned by: joshmouch
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description

If you extend the Array type like so: Array.prototype.dosomething = function(a,b) { /* do something */ };

And then try to open a dialog, there will be a button on the dialog called "dosomething".

Change History (4)

comment:1 Changed 8 years ago by tj.vantoll

Can you provide a test case? This works just fine for me - http://jsfiddle.net/j49Wz/

comment:2 Changed 8 years ago by Scott González

Owner: set to joshmouch
Status: newpending

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 7 years ago by Scott González

#8509 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.