Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#8035 closed bug (invalid)

Error when dragging and sorting

Reported by: neoniks Owned by: neoniks
Priority: minor Milestone: 2.0.0
Component: ui.draggable Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description

<html>

<head>
<script type="text/javascript" src="http://yandex.st/jquery/1.7.1/jquery.min.js"></script>
<script type="text/javascript" src="http://yandex.st/jquery-ui/1.8.17/jquery-ui.min.js"></script>
<title>test</title>
<script>
$(document).ready(function(){
	$( ".column" ).sortable({
            connectWith: ".column" ,
            cursor: 'crosshair',
            forceHelperSize: true,
            revert: true,
            forceHelperSize: true,
            dropOnEmpty: true,
            handle: '.ui-icon-muve'
    });
	$("#modmenu ul li.column_blok").draggable({
            connectToSortable:"ul.column",
            dropOnEmpty: true,
            helper: "clone",
            cursor:'point',
            appendTo: "#windowss"
        });

    $("ul.column").disableSelection();
});

</script>
<style>
	#modmenu ul,#modmenu li,#bod ul.column,#bod li.column_blok{list-style: none;display:block;margin:0;padding:5;}
	#modmenu li .ui-icon-muve{display:none;}
</style>
</head>

<body>

<div>
<table border="1" width="100%" id="modmenu">
		<tr>
			<td width="33%">
			<ul>
				<li id="el1" class="sys_blok column_blok"><span class="ui-icon-muve">X</span>123</li>
			</ul>
			</td>
			<td width="33%">&nbsp;</td>
			<td width="33%">&nbsp;</td>
		</tr>
		</table>
</div>

<div id="bod" style="border: 1px solid #000000">
<ul class="column" id="t1">
<li class="sys_blok column_blok">
<span class="ui-icon-muve">X</span>
<table border="1" width="100%">
	<tr>
		<td  width="50%" style="min-height: 50px"><ul class="column" id="t2"></ul></td>
		<td  width="50%" style="min-height: 50px"><ul class="column" id="t3"></ul></td>
	</tr>
</table></li>

</ul>
</div>

</body>

</html>

The code is fully working.

1) try to drag an item from a # t0 # t3 script will create a new item # 3 and why it will create two of the same element, but hidden 2) If popvtatsya move the new item in # t2 will be dvinatsya entire table rather than the newly created element 3) when sorting items from # t1 in # t2, not normally get them to move in the right place.

Change History (9)

comment:1 Changed 8 years ago by Scott González

Owner: set to neoniks
Status: newpending

Please stop dumping large blocks of code into tickets; create a reduced test case using jsFiddle or jsbin.

comment:2 Changed 8 years ago by Scott González

#8036 is a duplicate of this ticket.

comment:3 in reply to:  1 Changed 8 years ago by neoniks

Status: pendingnew

Replying to scott.gonzalez:

Please stop dumping large blocks of code into tickets; create a reduced test case using jsFiddle or jsbin.

http://jsfiddle.net/neoniks/s9C4D/4/

Here is an example of jsFiddle Look for the description of the actions above

comment:4 Changed 8 years ago by Scott González

I'm seeing #1 and #3, but not #2. Also, note that you still have duplicate IDs in your HTML. Your test case is extremely hard to follow, with tables and divs that have no labels, but lots of instructions on which elements to drag and where. If you can reduce your test even more and report one bug at a time, you'll have a better chance of these getting reviewed. However, all interactions are being rewritten from scratch for the 2.0 release, so it's unlikely that anyone on the team will be investigating these problems.

comment:5 in reply to:  4 Changed 8 years ago by neoniks

Replying to scott.gonzalez:

I'm seeing #1 and #3, but not #2. Also, note that you still have duplicate IDs in your HTML. Your test case is extremely hard to follow, with tables and divs that have no labels, but lots of instructions on which elements to drag and where. If you can reduce your test even more and report one bug at a time, you'll have a better chance of these getting reviewed. However, all interactions are being rewritten from scratch for the 2.0 release, so it's unlikely that anyone on the team will be investigating these problems.

You probably do not see it but there is, if a search.

http://jsfiddle.net/neoniks/hKg4x/ Here's another example that reveals one interaction. If you try to drag the gray box of yellow to blue, the blue will create 3 copies one of which is visible. Yet it is difficult to get to the desired item

comment:6 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:7 Changed 7 years ago by mikesherov

Status: newpending

Thanks for contributing! I too am having trouble reproducing or seeing what the problem is here. Please provide an even further reduced test case with clear instructions on how to reproduce the issue and what you're expecting to happen vs. what actually happens. Thanks again!

comment:8 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:9 in reply to:  8 Changed 7 years ago by neoniks

Replying to trac-o-bot:

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

The new version of the problem is gone. There is a new in Tubbs. About her again namishu ticket.

Note: See TracTickets for help on using tickets.