Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8036 closed bug (duplicate)

Error when dragging and sorting through all versions

Reported by: neoniks Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.core Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description

<html>

<head>
<script type="text/javascript" src="http://yandex.st/jquery/1.7.1/jquery.min.js"></script>
<script type="text/javascript" src="http://yandex.st/jquery-ui/1.8.17/jquery-ui.min.js"></script>
<title>test</title>
<script>
$(document).ready(function(){
	$( ".column" ).sortable({
            connectWith: ".column" ,
            cursor: 'crosshair',
            forceHelperSize: true,
            revert: true,
            forceHelperSize: true,
            dropOnEmpty: true,
            handle: '.ui-icon-muve'
    });
	$("#modmenu ul li.column_blok").draggable({
            connectToSortable:"ul.column",
            dropOnEmpty: true,
            helper: "clone",
            cursor:'point',
            appendTo: "#windowss"
        });

    $("ul.column").disableSelection();
});

</script>
<style>
	#modmenu ul,#modmenu li,#bod ul.column,#bod li.column_blok{list-style: none;display:block;margin:0;padding:5;}
	#modmenu li .ui-icon-muve{display:none;}
</style>
</head>

<body>

<div>
<table border="1" width="100%" id="modmenu">
		<tr>
			<td width="33%">
			<ul id="t0">
				<li id="el1" class="sys_blok column_blok"><span class="ui-icon-muve">X</span>123</li>
			</ul>
			</td>
			<td width="33%">&nbsp;</td>
			<td width="33%">&nbsp;</td>
		</tr>
		</table>
</div>

<div id="bod" style="border: 1px solid #000000">
<ul class="column" id="t1">
<li id="el1" class="sys_blok column_blok"><span class="ui-icon-muve">X</span>123</li>
<li id="el1" class="sys_blok column_blok"><span class="ui-icon-muve">X</span>123</li>
<li class="sys_blok column_blok">
<span class="ui-icon-muve">X</span>
<table border="1" width="100%">
	<tr>
		<td  width="50%" style="min-height: 50px"><ul class="column" id="t2"></ul></td>
		<td  width="50%" style="min-height: 50px"><ul class="column" id="t3"></ul></td>
	</tr>
</table></li>

</ul>
</div>

</body>

</html>

The code is fully working.

1) try to drag an item from a # t0 # t3 script will create a new item # 3 and why it will create two of the same element, but hidden 2) If popvtatsya move the new item in # t2 will be dvinatsya entire table rather than the newly created element 3) when sorting items from # t1 in # t2, not normally get them to move in the right place.

Change History (5)

comment:1 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

Why do you keep creating duplicate tickets? And why do your duplicate tickets have different HTML?

comment:2 Changed 8 years ago by Scott González

Duplicate of #8035.

comment:3 Changed 8 years ago by neoniks

Because the correct # 8036

8035 did not find how to remove

comment:4 in reply to:  2 Changed 8 years ago by neoniks

Replying to scott.gonzalez:

Duplicate of #8035.

Put the status of pending and then remove the 8305

in 8305 some invalid HTML

comment:5 Changed 8 years ago by Scott González

How about you do what you're supposed to and just create a reduced test case using jsFiddle or jsbin that we can actually test against and work with. Link to that from #8035.

Last edited 8 years ago by Scott González (previous) (diff)
Note: See TracTickets for help on using tickets.