Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#8142 closed bug (fixed)

Invalid negative CSS values from Accordion

Reported by: SineSwiper1 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.accordion Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Description

IE8 appears to be fairly strict about erroring out on invalid negative values being put into CSS properties that don't allow negative values. Animation easing methods such as 'easeInOutElastic' will dip into the negative in certain animation frames, and if that CSS property is one of the non-negative values, IE8 will immediately error.

My particular case involves the accordion animation line "options.toShow[ 0 ].style[ settings.prop ]" (percentDone is a negative number here). I don't know if jQuery core normalizes this when using its css() function, but direct accesses to the .style via JQUI would require checks when necessary.

I've audited the code for "style" and this appears to be the only line that would be affected by properties with negative values using direct accesses to .style. The following CSS properties cannot contain negative values, according to the W3C CSS2.1 standard (and certain CSS3 modules):

  • border-spacing
  • padding-top, padding-right, padding-bottom, padding-left, and padding
  • border-top-width, border-right-width, border-bottom-width, border-left-width, and border-width
  • border-top, border-right, border-bottom, border-left, and border (if specifying a width)
  • font-size and font (if specifying a size)
  • width and height
  • min-width, max-width, min-height, and max-height
  • line-height
  • outline-width and outline (if specifying a width)
  • widows

CSS3:

  • column-gap and column-rule-width
  • device-width, device-height, color, color-index, monochrome
  • marquee-play-count
  • background-size, border-image-slice, border-image-width, border-image-outset, box-shadow (only the blur radius)

Change History (3)

comment:1 Changed 8 years ago by Scott González

Resolution: fixed
Status: newclosed

I recently landed a change so that accordion leverages core's animation and no longer works directly with styles.

I also discussed this with Dave Methvin last night and this is now partially addressed in in core: http://bugs.jquery.com/ticket/11415

Accordion certainly shouldn't be handling this now that we're delegating to core. I'm going to close this as fixed since we go through the standard API now, so this can be handled by custom steps. I'll open a new ticket to discuss whether we want to land support for these in effects.core.

comment:2 Changed 8 years ago by Scott González

Created #8157.

comment:3 Changed 7 years ago by Scott González

#8346 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.