Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8346 closed bug (duplicate)

Nested Accordian Collapse/Expand Issue (IE8)

Reported by: RemyArmstro54 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.accordion Version: 1.8.20
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery UI encounters an error when you have an accordian whose content panels contain an accordian (nested accordian), and you try expanding the different content panels of the nested accordian.

Error Message = "Invalid Argument" Location of Thrown Message = jquery-ui-1.8.20.custom.js (using unminified default smoothness package in this example) line 4920 Statement Throwing Error = {{{jQuery UI encounters an error when you have an accordian whose content panels contain an accordian (nested accordian), and you try expanding the different content panels of the nested accordian.

Error Message = "Invalid Argument"

Location of Thrown Message = jquery-ui-1.8.20.custom.js (using unminified default smoothness package in this example) line 4920

Statement Throwing Error =

options.toShow[ 0 ].style[ settings.prop ] = ( percentDone * showProps[ settings.prop ].value ) + showProps[ settings.prop ].unit;

Occurs When = Right side of statement evaluates to "-1px"

To Reproduce = Download test code from http://sdrv.ms/KO1seV, run in IE8, and expand the first nested accordian's content panels.

Additional Comments = Removing the jquery ui css styles causes this issue to go away. Changing the padding (or other values that affect height) in the jquery ui accordian css causes the problem to shift around.

Change History (5)

comment:1 Changed 8 years ago by Scott González

Resolution: worksforme
Status: newclosed

I'm not seeing any problems: http://jsfiddle.net/FaW8K/

comment:2 Changed 8 years ago by RemyArmstro54

Clarification = You may have to try clicking on the 2nd or 3rd nested accordion sections to reproduce. Please try expanding all the different tabs to reproduce the error.

comment:3 Changed 8 years ago by Scott González

Resolution: worksforme
Status: closedreopened

comment:4 Changed 8 years ago by Scott González

Resolution: duplicate
Status: reopenedclosed

comment:5 Changed 8 years ago by Scott González

Duplicate of #8142.

Note: See TracTickets for help on using tickets.