Opened 7 years ago

Closed 6 years ago

#8197 closed bug (invalid)

start drag fails in ie7+8 when started on a element and distance set

Reported by: immoserver Owned by: immoserver
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Description

testcase: http://jsfiddle.net/yjjM5/2/

when you open the test in ie7+8 and start dragging a li on the text or the dot everything works fine. but when you start dragging on the a element "link" then the drag wont start.

When you remove the distance option it works.

Change History (7)

comment:1 Changed 7 years ago by immoserver

this also happens when the drag starts on an image, updated testcase: http://jsfiddle.net/yjjM5/4/

might be related to ticket #7359 other browsers work fine.

comment:2 Changed 7 years ago by Scott González

It's going to be true for anything that's natively draggable.

comment:3 Changed 7 years ago by immoserver

I've done a little research and stumbled upon this fix: http://davidwalsh.name/prevent-internet-explorers-default-image-dragging-action

adding this line

document.ondragstart = function () { return false; };

disables IEs native dragging "feature" and resolves the problem.

shouldnt draggable/sortable add this when needed ?

comment:4 Changed 7 years ago by Scott González

Asynchronous determination of whether to handle an interaction is actually a much larger issue than just completely disabling native drag.

comment:5 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:6 Changed 7 years ago by mikesherov

Owner: set to immoserver
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! I can no longer reproduce the issue using the latest jQuery and jQuery UI using the info provided. http://jsfiddle.net/JC45E/

If you can still reproduce it, please feel free to reply to this ticket with a test case showing the problem. Thanks!

comment:7 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.