Opened 7 years ago

Closed 7 years ago

#8253 closed bug (duplicate)

Wrong dialog closes on pressing esc twice on multiple modal dialogs

Reported by: AllanKnox Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Description

If multiple modal dialogs are opened, the close-order on pressing the escape-key is wrong.

See: http://jsfiddle.net/Plasm/QFkH9/

=> at start: Dialog 1 opens

  • click "open Dialog 2"

=> Dialog 2 opens

  • click "open Dialog 3"

=> Dialog 3 opens

  • press escape-key

=> Dialog 3 closes

  • on Chrome, Opera and Safari: click at the grayed area outside the dialogs (this step is optional in FF and IE)

=> nothing visible happens

  • press escape-key again

=> Dialog 1 closes

Tested on FF11, IE9, Opera 11.62, Safari 5.1.1 and Chrome 18 (all on Win 7). The bug exists at least since 1.8.17 (probably older)

I haven´t managed to get a workaround by using .dialog( "moveToTop" ) at Dialog 2 after closing Dialog 3. Triggering .focus() didn´t work as well.

Change History (4)

comment:1 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:2 Changed 7 years ago by drewkimrey

Status: newopen

I wasn't able to replicate dialogs closing in the wrong order, however I did notice that if multiple dialogs are open the parent dialog isn't focused after esc http://jsfiddle.net/wDr87/1/

comment:3 Changed 7 years ago by AllanKnox

Indeed, seems the bug is (half-)fixed in 1.9.0. I studied the changelog and found a duplicate ticket that is now fixed: http://bugs.jqueryui.com/ticket/8300 However, the focus problem persists, as you described.

comment:4 Changed 7 years ago by Scott González

Resolution: duplicate
Status: openclosed

Duplicate of #8300.
The focus on close behavior will change with the API redesign.

Note: See TracTickets for help on using tickets.