Opened 8 years ago

Closed 7 years ago

#8296 closed bug (fixed)

Button and Radio Set not initialized in generated index.html

Reported by: DouglasKing Owned by: DouglasKing
Priority: minor Milestone: 1.9.0
Component: [meta] ui.downloadbuilder Version: 1.8.20
Keywords: Cc:
Blocked by: Blocking:

Description

Hello

When in the jQuery Theme Roller design interface I customise my design, all elements render fine in the preview. When I download the theme and open index.html on my local machine all elements except for the button and radioset work and render fine. For the button element a normal button is displayed not themed as per the ThemeRoller, for the radioset a normal set of radio buttons are displayed.

I've tried 3 different themes as well as viewing on 2 different machines with the same result. For some reason the button and radioset elements are not being skinned in the downloaded theme set.

Any assistance would be appreciated, thank you for your support.

Kind Regards Douglas

Change History (8)

comment:1 Changed 8 years ago by Scott González

Owner: set to DouglasKing
Status: newpending

Did you not include the button widget in your download?

comment:2 in reply to:  1 Changed 8 years ago by DouglasKing

Status: pendingnew

Yes I did. The css file contains all the Button UI elements.

Replying to scott.gonzalez:

Did you not include the button widget in your download?

comment:3 Changed 8 years ago by Scott González

Component: ui.button[meta] ui.downloadbuilder
Status: newopen
Summary: Button and Radio Set not themingButton and Radio Set not initialized in generated index.html

Oh, I see. The index page is busted (the buttons are never initialized). The themes work fine.

comment:4 in reply to:  3 Changed 8 years ago by DouglasKing

Makes sense. Wow what service, you guys are really on top of your game. Thanks again. All the best.

Replying to scott.gonzalez:

Oh, I see. The index page is busted (the buttons are never initialized). The themes work fine.

comment:5 Changed 8 years ago by Scott González

#8315 is a duplicate of this ticket.

comment:6 Changed 7 years ago by rdworth

Found that this issue exists on jqueryui.com but not on ui-dev.jquery.com . Thought I'd share in case that helps track down the source.

comment:7 Changed 7 years ago by Scott González

#8386 is a duplicate of this ticket.

comment:8 Changed 7 years ago by Scott González

Resolution: fixed
Status: openclosed

This is fixed in the new download builder.

Note: See TracTickets for help on using tickets.