Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8311 closed bug (duplicate)

Datepicker won't close when double-clicked

Reported by: mnbayazit Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.20
Keywords: Cc:
Blocked by: Blocking:

Description

See http://stackoverflow.com/q/10538351/65387 for discussion.

HTML

<a href="#">double click me</a><input/>​

JavaScript

$('input').datepicker();
$('a').click(function() {
    $('input').datepicker('show');
});​

When you double-click the link the calendar opens but then becomes unclosable.

This seems to happen whenever you call 'show' twice before the fade animation completes.

Change History (2)

comment:1 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

Please test against the latest release before reporting bugs. This was fixed two versions ago.

comment:2 Changed 8 years ago by Scott González

Duplicate of #8174.

Note: See TracTickets for help on using tickets.