Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#8174 closed bug (fixed)

jQuery datepicker is stuck open if label is clicked from open state.

Reported by: lalalamoo Owned by:
Priority: minor Milestone: 1.8.19
Component: ui.datepicker Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Description

I read about the problem here: http://stackoverflow.com/questions/9427073/jquery-datepicker-is-stuck-open-if-label-is-clicked-from-open-state

Then saw the bug wasn't already filed in the bugtracker and decided to post this.

Basically changing

self._curInst = null;

to

this._curInst = null;

in Datepicker.prototype._hideDatepicker, postProcess() seems to fix the bug.

Change History (10)

comment:1 Changed 5 years ago by scottgonzalez

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 5 years ago by scottgonzalez

Duplicate of #7722.

comment:3 Changed 5 years ago by lalalamoo

Actually I tested with 1.8.18 and the problem is still there!

Basically clicking on a label when the datepicker is open makes the widget stuck open.

If you could please read again the problem on the link I provided you'd realize that 1.8.18 is still affected.

Thanks.

comment:4 Changed 5 years ago by scottgonzalez

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:5 Changed 4 years ago by scottgonzalez

#8228 is a duplicate of this ticket.

comment:6 Changed 4 years ago by scottgonzalez

  • Status changed from reopened to open

Waiting on a response to #7722. The proposed fix in this ticket is definitely wrong, as noted in the SO thread. Removing the line would be better than assigning a value to a DOM element.

comment:7 Changed 4 years ago by Scott González

  • Resolution set to fixed
  • Status changed from open to closed

Datepicker: Don't set _curInst in hideDatepicker. Fixes #8174 - jQuery datepicker is stuck open if label is clicked from open state.

Changeset: 4ade13450e7145100dcce3356eb1449e1a5f7090

comment:8 Changed 4 years ago by Scott González

Datepicker: Don't set _curInst in hideDatepicker. Fixes #8174 - jQuery datepicker is stuck open if label is clicked from open state. (cherry picked from commit 4ade13450e7145100dcce3356eb1449e1a5f7090)

Conflicts:

ui/jquery.ui.datepicker.js

Changeset: fc6e72bf7399ecde5f15de88fd750a9a49b55b77

comment:9 Changed 4 years ago by scottgonzalez

  • Milestone changed from 1.9 to 1.8.19

comment:10 Changed 4 years ago by scottgonzalez

#8311 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.