Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8340 closed bug (duplicate)

Error: this.placeholder[0].parentNode is null

Reported by: Blackbird Owned by: Blackbird
Priority: minor Milestone: 1.9.0
Component: ui.sortable Version: 1.8.20
Keywords: Cc:
Blocked by: Blocking:

Description

In function _clear(), there is the following line:

this.placeholder[0].parentNode.removeChild(this.placeholder[0]);

A check is missing IMO. In my code this.placeholder[0].parentNode is null when the above line is executed, therefore displaying an error in the Javascript console.

Change History (6)

comment:1 Changed 7 years ago by Scott González

Owner: set to Blackbird
Status: newpending

Please provide details about the actual bug. What are you doing that causes the error? Please create a reduced test case in jsFiddle or jsbin showing the bug.

comment:2 Changed 7 years ago by Blackbird

Status: pendingnew

Hi Scott,

I hadn't seen your answer (can one be notified by email?) I understand sample code would be helpful. I'll try to find the time but cannot guarantee it: the page with the bug is pretty complicated and so it's at least half of day of work to extract the problematic part.

Edit: Posting this reply automatically updated the bug's status back to "new", I didn't do anything for that.

Last edited 7 years ago by Blackbird (previous) (diff)

comment:3 in reply to:  2 Changed 7 years ago by Scott González

Status: newpending

Replying to Blackbird:

I hadn't seen your answer (can one be notified by email?)

Yes, if you had provided an email address when you created your account, you would have been notified. You should update your account.

I understand sample code would be helpful. I'll try to find the time but cannot guarantee it: the page with the bug is pretty complicated and so it's at least half of day of work to extract the problematic part.

If you have encountered the bug and will have difficulty reproducing it, how long do you think it will take us to try to reproduce it from scratch?

Edit: Posting this reply automatically updated the bug's status back to "new", I didn't do anything for that.

You replied, which is what the pending status is all about.

comment:4 Changed 7 years ago by Blackbird

Status: pendingnew

Extracted the bug: http://jsfiddle.net/YunGx/7/

How-to: 1) Drag one item from the Unpublish list to the Publish list. Repeat. -> No problem

2) Change the order of the two items in the Publish list -> No problem

3) Drag an item from the Publish list back to the Unpublish list -> Bug!

comment:5 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:6 Changed 7 years ago by Scott González

Duplicate of #6054.

Note: See TracTickets for help on using tickets.