Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#8399 closed bug (fixed)

Draggable: focusable elements do not get focus

Reported by: kdinev2 Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.draggable Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Description

After instantiating draggable on a focusable element, I can no longer focus it with mouse interaction.

E.g. http://jsbin.com/okavip/2/edit#preview

Steps to reproduce if the above e.g. doesn't work:

  1. Create a page with two anchors.
  2. Instantiate draggable on one of them.
  3. Notice the draggable anchor cannot be focused with the mouse.

Reproducible in: IE9; FF

Assumption:

I have not referred to the draggable source code, but I assume that the mousedown event is being cancelled.

Change History (9)

comment:1 Changed 5 years ago by Scott González

Preventing the default action is a requirement for implementing drag and drop, but we should probably move focus on drag.

comment:2 Changed 5 years ago by kdinev2

It would be great if you could do so. Thanks!

comment:3 Changed 5 years ago by kdinev2

I have something to add. The draggable doesn't work at all in IE8/IE7 document mode on focusable elements. It works fine with a <div> but not with <a>.

comment:4 Changed 5 years ago by kdinev2

Any updates on this, because it still is quite an issue that the draggable doesn't work at all under IE7/IE8 when instantiated on a focusable element?

comment:5 Changed 5 years ago by Scott González

Milestone: 1.9.02.0.0

comment:6 Changed 4 years ago by mikesherov

Status: newopen

comment:7 Changed 4 years ago by Scott González

Related to #4261

comment:8 Changed 4 years ago by Steven Luscher

Resolution: fixed
Status: openclosed

Clicking on a draggable anchor without moving it should make it the active element (Fixes #8399).

Changeset: bca3e058e89bf40806170149b8029dfe52644248

comment:9 Changed 4 years ago by mikesherov

Milestone: 2.0.01.11.0
Note: See TracTickets for help on using tickets.