Opened 7 years ago

Closed 6 years ago

#8436 closed bug (worksforme)

sortable doesn't play well with IE7 and radio or checkboxes inputs

Reported by: rosenfeld Owned by: rosenfeld
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.21
Keywords: Cc:
Blocked by: Blocking:

Description

This is the same bug as #6137, but it only seems to be fixed for dialogs.

http://bugs.jqueryui.com/ticket/6137

If you drag some sortable, jQuery UI will detach the li element without storing the values for checkboxes and radio inputs for restoring them when reattaching it.

IE7 has a bug that prevent the checked attribute from being persisted for those inputs unless they're present in the DOM.

Change History (4)

comment:1 Changed 6 years ago by Scott González

Milestone: 1.9.02.0.0

comment:2 Changed 6 years ago by petersendidit

Owner: set to rosenfeld
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the git version of both jQuery UI and jQuery to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/ZgAqH/Open the link and click to "Fork" (in the top menu) to get started.

comment:3 Changed 6 years ago by rosenfeld

Status: pendingnew

I can't reproduce this anymore, even on jQuery 1.7.2 and jQuery UI 1.8.21:

http://jsfiddle.net/rosenfeld/aQBsV/

I don't know what version of jQuery I was using by that time... Maybe some other library was taking influence on this behavior when I experienced it.

You can close this ticket.

comment:4 Changed 6 years ago by Scott González

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.