Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8534 closed feature (duplicate)

Missing Accessibility (features) in ui.dialog?

Reported by: soophie Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.9.0-rc.1
Keywords: Cc:
Blocked by: Blocking:

Description

I'm new in accessibility and javascript, but I think, there could be some improvements for ui.dialog.

First: I think, all layers, modals, dialogs should have the close-link at the end of generated source code. This way the user can use focus and reach the close button after the content. Now you can reach the button only by going back, if you have another links in your content, by hitting shift + tab.

Second: Is there a possibility, that after closing dialog the element is focused, that opened the dialog? Mostly there are links or buttons, that opens a dialog. At the moment after closing a dialog my focus is gone and I have to start again from the top.

Please tell me, if I'm using it wrong or if you have workarounds, but right now, I'm very unsure, if I can use ui.dialog in an project, that has to be accessible.

  • soophie

Change History (2)

comment:1 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

The close link is in the correct place, tabbing should wrap inside dialogs. See #7861 and #7862. Dialog accessibility will be fixed in 1.10.

comment:2 Changed 7 years ago by Scott González

Duplicate of #7861.

Note: See TracTickets for help on using tickets.