Opened 7 years ago

Last modified 4 years ago

#8556 open bug

Datepicker: Showing a datepicker while another datepicker is closing causing the newly opened datepicker to close

Reported by: kinglozzer Owned by: kinglozzer
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.8.23
Keywords: Cc:
Blocked by: Blocking:

Description

When moving between two Datepicker fields, using $('id').datepicker("show");, the second datepicker appears and then disappears.

http://jsfiddle.net/MPQsR/

Problem can be avoided by doing setTimeout(function(){show datepicker}, 0);

Change History (14)

comment:2 Changed 7 years ago by Scott González

Owner: set to kinglozzer
Status: newpending

I'm not seeing this behavior. Is this happening in a specific browser?

comment:3 Changed 7 years ago by Scott González

Resolution: invalid
Status: pendingclosed

I see the bug in the first fiddle, which uses 1.9.0rc1 + a 1.8 theme, but not in the second which uses 1.8.23. I also do not see this when using jquery-ui-git.

comment:4 Changed 7 years ago by kinglozzer

Sorry I forked the first fiddle from a different bug, the second one is the one in question.

I've tried it in Chrome, Firefox and Safari on OSX 10.7.4 and the behaviour is the same in all three; when selecting a date, the second datepicker opens and then closes a split second later - but doesn't when I use setTimeout

comment:5 Changed 7 years ago by kinglozzer

Just tested on VMWare Windows and it works, so I guess it's a Mac only bug. If it helps track it down; when it flashes on then off, if I then switch to a different window/program and switch back, it reappears.

comment:6 Changed 7 years ago by Scott González

Resolution: invalid
Status: closedreopened

The description was not very clear, it sounded like you just wanted us to click in the text fields.

comment:7 Changed 7 years ago by Scott González

Milestone: 1.9.01.11.0

comment:8 Changed 7 years ago by mikesherov

Status: reopenedopen

comment:9 Changed 7 years ago by tj.vantoll

#9236 is a duplicate of this ticket.

comment:10 Changed 7 years ago by tj.vantoll

Summary: Datepicker flashes when moving between two fieldsDatepicker: flashes when moving between two fields

Reduced test case against master: http://jsfiddle.net/tj_vantoll/5udAh/

comment:12 Changed 5 years ago by Scott González

Milestone: 1.11.0none

comment:13 Changed 4 years ago by Scott González

Summary: Datepicker: flashes when moving between two fieldsDatepicker: Showing a datepicker while another datepicker is closing causing the newly opened datepicker to close

comment:14 Changed 4 years ago by Scott González

Likely caused by the same bug that causes #8907. Both should be non-issues with the rewrite since there's no more singleton.

Note: See TracTickets for help on using tickets.