Opened 7 years ago

Closed 7 years ago

#8599 closed bug (duplicate)

Autocomplete menu is not repositioned when page reflows

Reported by: JessePelton Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.23
Keywords: Cc:
Blocked by: Blocking:

Description

Autocomplete menus are positioned relative to another element. If the position of that element changes while its menu is displayed (perhaps because the browser window changed size, or the text size changed), the menu remains where it was.

I've worked around this in my application with a window resize event handler, but it's somewhat ugly and fragile. I think it would be cleaner if the widget handled repositioning itself. (At least for resize events. If the input is repositioned by script, I think it's reasonable to require the script to reposition the menu as well.)

Test case (with additional commentary): http://jsbin.com/orifoy/1/.

Whether this is a bug or a feature request may be in the eye of the beholder.

Change History (1)

comment:1 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #8469.

Note: See TracTickets for help on using tickets.