Opened 7 years ago

Closed 7 years ago

#8604 closed bug (duplicate)

resizable inside resizable object

Reported by: zackniwa Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.resizable Version: 1.8.23
Keywords: Cc:
Blocked by: Blocking:

Description

The issue is simple, I have a div, which is resizable, and another div, resizable too, inside the first resizable div. The handles are the same, but when I want to resize the parent div, nothing happen. The div inside is working perfectly with all the setting, but it block the resize of the parent. There is a sample source code of that issue.

<script>
	$('#ok_div').resizable({handles:'e'});
	$('#error_div').resizable({containment:'#error_div',handles:'e'});
</script>


<div id="error_div" style="width:200px; height: 200px;border: 1px solid #F00;">
	<div id="ok_div" style="width:100px; height: 100px;border: 1px solid #000;">
	</div>
</div>

Sorry, I work locally so I have no link to provide with this example. All you have to do is include Jquery UI with resizable core.

And sorry for my english, I'm not really good.

JQuery Version 1.8.1

Jquery UI Version 1.8.23

Change History (4)

comment:1 Changed 7 years ago by zackniwa

Sorry, I sent an error in my containment: Here's the correction.

<script>
	$('#ok_div').resizable({containment:'#error_div',handles:'e'});
	$('#error_div').resizable({handles:'e'});
</script>


<div id="error_div" style="width:200px; height: 200px;border: 1px solid #F00;">
	<div id="ok_div" style="width:100px; height: 100px;border: 1px solid #000;">
	</div>
</div>

comment:2 Changed 7 years ago by zackniwa

I found a solution, but this issue still remaining for that case.

The problem of this is issue is the call order. If you switch the 2 lines of javascript code, everything works fine.

So the problem is the call order, it will be nice to not have a problem like this in the future release.

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:4 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #5025.

Note: See TracTickets for help on using tickets.