Opened 7 years ago

Closed 3 years ago

Last modified 3 years ago

#5025 closed bug (fixed)

Resizable: Elements that have inner resizable elements do not work

Reported by: dosinovsky Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.resizable Version: 1.7.2
Keywords: haspatch Cc:
Blocked by: Blocking:

Description

  1. Create resizable inside another resizable with the same type of handles (for example, both have 'e' handle). 'handles' option must be given as string.
  1. Initialize inner resizable first and after that initialize outer.
  1. Now try to resize outer resizable - it doesn't work.

In debugger you can see that in _mouseCapture function this expression $(this.handles[i])[0] returns handle of inner resizable instead of outer.

How to fix: In this._renderAxis find this lines if(this.handles[i].constructor == String)

this.handles[i] = $(this.handles[i], this.element).show();

and change last line to

this.handles[i] = $(this.handles[i] + ':last', this.element).show();

Change History (7)

comment:1 Changed 7 years ago by Scott González

Milestone: TBD1.8

comment:2 Changed 5 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 5 years ago by tj.vantoll

Status: newopen
Summary: resizable element which have inner resizable elements doesn't workResizable: Elements that have inner resizable elements do not work

Verified that this is still an issue in 1.9.1 - http://jsfiddle.net/bLKUU/.

comment:4 Changed 5 years ago by tj.vantoll

Keywords: haspatch added

comment:5 Changed 5 years ago by tj.vantoll

#8604 is a duplicate of this ticket.

comment:6 Changed 3 years ago by Jyoti Deka

Resolution: fixed
Status: openclosed

Resizable: modified to allow resizing when resizables are nested.

Fixes #5025 Closes gh-1149

Changeset: ec5f395260c5e4b678d2fe39c5405d466ee8369e

comment:7 Changed 3 years ago by mikesherov

Milestone: 2.0.01.11.0
Note: See TracTickets for help on using tickets.