Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8626 closed bug (fixed)

Programatically opening a tooltip with out giving an event results in a javascript error.

Reported by: mdownes Owned by:
Priority: minor Milestone: git
Component: ui.tooltip Version: 1.9.0-rc.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

I am receiving a javascript error when i try to programatically open a tooltip using the open() method.
I am not passing an event as a parameter as i have none.

The documentation states ......"event object is only necessary for delegated tooltips so the widget knows which element to show the tooltip for"

The problem is the following line where there is no check to see if the event exists:

if ( this.options.track && /^mouse/.test( event.originalEvent.type ) ) {

Please review the following test case:

http://jsfiddle.net/Dh9ZW/

Kind Regards,

Maurice

Change History (2)

comment:1 Changed 7 years ago by Scott González

Resolution: fixed
Status: newclosed

Tooltip: Check if event exists before checking properties in open(). Fixes #8626 - Programatically opening a tooltip with out giving an event results in a javascript error.

Changeset: 96f2aa4c72b5f29782b0736ed95468e50d338d6e

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.0git
Note: See TracTickets for help on using tickets.