Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8656 closed bug (fixed)

Initial position of autocomplete is incorrect

Reported by: Corwin Owned by:
Priority: minor Milestone: 1.9.1
Component: ui.autocomplete Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

JsFiddle: http://jsfiddle.net/Q6kk4/

Click in the text box and type a "t". The autocomplete box will be slightly to the left. This only occurs on the initial keypress after the page loads and will display normally if one continues to type. This did not occur in 1.8.24 and has been observed in Chrome 22 and IE 9.

Change History (6)

comment:1 Changed 7 years ago by Scott González

Status: newopen

Confirmed in IE9, but works fine for me in Chrome 21.

comment:2 Changed 7 years ago by Scott González

This only occurs with body { margin: 0; }

comment:3 Changed 7 years ago by Scott González

Resolution: cantfix
Status: openclosed

This isn't something that we can handle in autocomplete. I've filed a ticket for the underlying problem: http://bugs.jquery.com/ticket/12706

comment:4 Changed 7 years ago by Scott González

Resolution: cantfix
Status: closedreopened

Turns out that absolutely positioned elements aren't really absolutely positioned if you don't position them...

comment:5 Changed 7 years ago by Scott González

Resolution: fixed
Status: reopenedclosed

Autocomplete: Set the top position of the menu so that the menu doesn't affect layout. Fixes #8656 - Initial position of autocomplete is incorrect.

Changeset: 1ee090ea9e03c800a764d992506869384409bdb6

comment:6 Changed 7 years ago by Scott González

Milestone: 1.10.01.9.1
Note: See TracTickets for help on using tickets.