Opened 7 years ago

Closed 7 years ago

#8675 closed bug (fixed)

Dialog: Position with pixels in array doesn't work with back compat disabled

Reported by: Mamen Owned by:
Priority: blocker Milestone: 1.9.1
Component: ui.dialog Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

$("#dialog").dialog({position: [200, 200]});

This will render the same as [0, 0]. String values DO work. For example ['center', 'center']

Change History (8)

comment:1 Changed 7 years ago by Scott González

Resolution: worksforme
Status: newclosed

comment:2 Changed 7 years ago by Mamen

It doesn't work at all here. However my inital statement was somewhat wrong. In IE, and Chrome it defaults to "center center" if numerics are used. In Opera it defaults to "center top".

comment:3 Changed 7 years ago by Mamen

Hmm. I suspect this may be related to frames. The problem is most prominent with Opera. In all browsers I have tested, it works when selecting the live preview (stand alone page). May be problems with changing values live also.

comment:4 Changed 7 years ago by Scott González

I'm still not seeing any problems. The behavior you're seeing in Opera with the dialog showing at the top is caused by the fact that the document doesn't have enough height. Add another element to the page that actually makes the document taller and you'll see the positioning is working just fine.

comment:5 Changed 7 years ago by Mamen

May be something like that. However it fill fail in all browsers if you add

<script>$.uiBackCompat = false;</script>

The reason is that dialog uses offset, which is depricated. The option [200,200] is however NOT marked as depricated.

comment:6 Changed 7 years ago by Scott González

Milestone: 1.10.01.9.1
Priority: minorblocker
Resolution: worksforme
Status: closedreopened
Summary: dialog: position with pixels in array doesn't workDialog: Position with pixels in array doesn't work with back compat disabled

comment:7 Changed 7 years ago by Scott González

Status: reopenedopen

comment:8 Changed 7 years ago by Scott González

Resolution: fixed
Status: openclosed

Dialog: Don't use deprecated offset option for .position(). Fixes #8675 - Dialog: Position with pixels in array doesn't work with back compat disabled.

Changeset: 11effcbd35c7a0b36af2a710b385d741f5849cbf

Note: See TracTickets for help on using tickets.