Opened 7 years ago

Closed 7 years ago

#8713 closed bug (fixed)

Passing an object as ui.resizable handles parameter does not work

Reported by: maimairel Owned by:
Priority: blocker Milestone: 1.9.1
Component: ui.resizable Version: 1.9.0
Keywords: regression Cc:
Blocked by: Blocking:

Description

Passing an object with a selector as the handles parameter on ui.resizable 1.9 triggers a bug because the merged handles option is split into an array of strings like this:

"e", ",", "s", ",", "se", ",", "#your-selector"

This is caused by the new Widget.extend method.

Change History (2)

comment:1 Changed 7 years ago by Scott González

Keywords: regression added
Milestone: 1.10.01.9.1
Priority: minorblocker
Status: newopen

comment:2 Changed 7 years ago by Scott González

Resolution: fixed
Status: openclosed

Widget: $.widget.extend(): Properly handle extending a string with an object. Fixes #8713 - Passing an object as ui.resizable handles parameter does not work.

Changeset: 9b908878ae3a9c0fbbd9958b579f223a648c5c69

Note: See TracTickets for help on using tickets.