Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8739 closed bug (fixed)

Tooltip: Default positioning on large items off

Reported by: dsargent@… Owned by:
Priority: minor Milestone: 1.9.2
Component: ui.tooltip Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

Example: http://jqueryui.com/tooltip/#custom-content Hover over Viena Austria link that is supposed to open a map (due to the new position it doesn't work so well in the demo, which also needs fixed). The background border image does not size well to the large item in the box. I see this will my own content when loading an image. If memory serves, this worked well in 1.9 but does not in 1.9.1

Change History (6)

comment:1 Changed 7 years ago by tj.vantoll

Status: newopen
Summary: Tooltip background does not size well to large items.Tooltip: Default positioning on large items off

Thanks for taking the time to contribute to the jQuery UI project! The demo is definitely broken. Probably caused by this commit - https://github.com/jquery/jquery-ui/commit/7af1ec727bcca8367e804cea77b9dd238b1c0d69. In general you can always override the position using the position option - http://api.jqueryui.com/tooltip/#option-position.

comment:2 Changed 7 years ago by Jörn Zaefferer

We can fix that demo by overriding two things: .ui-tooltip { max-width: 350px } and position: { collision: "flipfit flip" }

Though I think we really need to change the default collision for tooltip. We shouldn't allow vertical fit, as that can cause the tooltip to overlap the tooltipped element, which should never be allowed to happen.

Last edited 7 years ago by Jörn Zaefferer (previous) (diff)

comment:3 Changed 7 years ago by Jörn Zaefferer

Talked with Scott about this: We'll set max-width:350 in the demo and make the collision default "flipfit flip" for tooltip.

comment:4 Changed 7 years ago by Jörn Zaefferer

Resolution: fixed
Status: openclosed

Tooltip: Make 'flipfit flip' the collision default to avoid the tooltip ever overlapping the trigger. Also fix max-width for custom-content demo. Fixes #8739 - Tooltip: Default positioning on large items off.

Changeset: 1d9eab1ead0d5a6f60e31437bb539eb3f804bacc

comment:5 Changed 7 years ago by Jörn Zaefferer

Tooltip: Make 'flipfit flip' the collision default to avoid the tooltip ever overlapping the trigger. Also fix max-width for custom-content demo. Fixes #8739 - Tooltip: Default positioning on large items off. (cherry picked from commit 1d9eab1ead0d5a6f60e31437bb539eb3f804bacc)

Changeset: fbc0e6afe6cb277f7e8b91817484cdcd002afc32

comment:6 Changed 7 years ago by Scott González

Milestone: 1.10.01.9.2
Note: See TracTickets for help on using tickets.