Opened 7 years ago

Closed 3 years ago

#8746 closed bug (wontfix)

Tooltip: Both Jquery tooltip and standard title shown in IE < 10

Reported by: jpuntomarcos Owned by:
Priority: minor Milestone: none
Component: ui.tooltip Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

Both Jquery new tooltip and standard title are being shown sometimes if you set "delay" option when creating Tooltip.

See fiddle example (Try several times)

It is happening in IE 9 and 8, not in Chrome or Firefox.

Change History (15)

comment:1 Changed 7 years ago by tj.vantoll

Status: newopen
Summary: Both Jquery tooltip and standard title shown in IETooltip: Both Jquery tooltip and standard title shown in IE

Confirmed. I was able to get this to happen in IE7 as well.

comment:2 Changed 7 years ago by Jörn Zaefferer

The first two or three times, the both show up, then only the UI tooltip.

comment:3 Changed 7 years ago by Jörn Zaefferer

I'm unable to reproduce this outside of jsfiddle.

The only suspect block of code is this, as that timer might explain why this issue doesn't show up every time: https://github.com/jquery/jquery-ui/blob/0bff32a2b1c2273e46dc0f70bc1058ad304ebcc5/ui/jquery.ui.tooltip.js#L270-280 I'm not sure why we run that without check also for the track option.

comment:4 in reply to:  3 Changed 7 years ago by Scott González

Replying to joern.zaefferer:

I'm not sure why we run that without check also for the track option.

Good question. We could certainly add that check.

comment:5 Changed 7 years ago by cedricbrasey

This doesn't seem to happen in IE10

comment:6 Changed 7 years ago by yoann

This bug occurs also if you set "track" option.

comment:7 Changed 7 years ago by tj.vantoll

Milestone: 1.10.0none

comment:8 Changed 7 years ago by tj.vantoll

Summary: Tooltip: Both Jquery tooltip and standard title shown in IETooltip: Both Jquery tooltip and standard title shown in IE < 10

Per #9222 this can happen with a really simple example: http://jsfiddle.net/tj_vantoll/p2CJK/. I can recreate the problem in IE7, 8, and 9 but not IE 10 which is consistent with @cedricbrasey's comment. It is sporadic though.

comment:9 Changed 7 years ago by tj.vantoll

#9222 is a duplicate of this ticket.

comment:10 Changed 6 years ago by ever4us

I get double tooltips with asp.net buttons but NOT with asp.net labels). AND the standard tooltip only shows if the cursor is placed over the button text. It does not show if the cursor is placed over the button outside of the button's text area.

comment:11 Changed 6 years ago by hugodevreugd

When I change tj.vantoll's example by placing a copy of the button below the orignal one, and move from the upper to the lower button, I get double tooltips.

I am using IE10 version 10.0.9200.16599.

comment:12 Changed 6 years ago by jeffwong

I faced this same issue, when tooltip set for textbox and using tab from first textbox to next textbox, the tooltip show double.

I'm also tested it on http://jsfiddle.net/tj_vantoll/p2CJK/ and get the same result.

(IE 10.0.9200)

comment:13 Changed 6 years ago by Volodymyr Oliinyk

Can reproduce in IE11 - both tooltips are shown (standard and jQuery).

http://jsfiddle.net/LVwfc/1/ Just set mouse from outside to the border of the div block (in IE11).

comment:14 in reply to:  13 Changed 6 years ago by tj.vantoll

Replying to Volodymyr Oliinyk:

Can reproduce in IE11 - both tooltips are shown (standard and jQuery).

http://jsfiddle.net/LVwfc/1/ Just set mouse from outside to the border of the div block (in IE11).

I'm not seeing this personally. Also your test case is using an old version of jQuery UI 1.9.2. You can use the following test case as a starting point - http://jsfiddle.net/tj_vantoll/FMUZL/ (it's setup to use the latest code from the master branch of the git repo).

comment:15 Changed 3 years ago by Scott González

Resolution: wontfix
Status: openclosed

We don't support these versions of IE anymore.

Note: See TracTickets for help on using tickets.