Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9222 closed bug (duplicate)

In IE, default tooltip appears instead of jquery tooltip...:(

Reported by: mgahlot Owned by: mgahlot
Priority: minor Milestone: none
Component: ui.tooltip Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

I tried to use tooltip in one demo application & I found that jQuery tooltip which gets populated on component which contains title attribute. It works fine in chrome & Firefox but shows default tooltip (browser) above the jQuery tooltip in IE8.

Change History (14)

comment:1 Changed 6 years ago by Scott González

Component: ui.coreui.tooltip
Owner: set to mgahlot
Status: newpending

Do the demos on http://jqueryui.com/tooltip/ work for you?

We'll need a reduced test case showing the problem.

comment:2 Changed 6 years ago by mgahlot

Status: pendingnew

Hi, Please see the attached demo link...

https://dl.dropboxusercontent.com/u/110099535/HTML/A.html

comment:3 Changed 6 years ago by tj.vantoll

Status: newpending

I cannot recreate this in IE8, but from your screenshot this appears to be a duplicate of #8746. Are you doing anything special or are you just mousing over the button?

comment:4 Changed 6 years ago by mgahlot

Status: pendingnew

Hi, I am not doing any special thing, you can see the source of the demo and can reproduce the same on IE8. As I think, at some place in code, we missed to disable the default tooltip or might have to put fix for IE8.

comment:5 Changed 6 years ago by Scott González

Resolution: worksforme
Status: newclosed

I also cannot reproduce this.

comment:6 Changed 6 years ago by mgahlot

Hi,

can you please provide the link of your demo on which it is not reproducing in IE8 ?

comment:7 Changed 6 years ago by Scott González

https://dl.dropboxusercontent.com/u/110099535/HTML/A.html (your demo does not show the error for me or tj.vantoll)

comment:8 Changed 6 years ago by tj.vantoll

Resolution: worksforme
Status: closedreopened

I couldn't recreate this in BrowserStack but I just was able to recreate it in a Windows XP VM. I'm pretty confident this is a duplicate of #8746 but I want to play with this a little.

comment:9 Changed 6 years ago by tj.vantoll

Status: reopenedpending

@mgahlot I'm having a lot of trouble recreating this but I have seem the problem occur at least twice now. Are you able to consistently recreate the problem or is it sporadic? What version of Windows are you running? Does the problem occur in other versions of Internet Explorer.

Any information you can provide would help. Thanks.

comment:10 Changed 6 years ago by mgahlot

Status: pendingnew

Hi, Yes, I am able to see this problem consistently in IE8. We are using window 7 OS & we have checked the same on IE9 also but facing the same problem.

comment:11 Changed 6 years ago by tj.vantoll

Status: newpending

I see the issue in IE8 and IE9 occasionally.

I do not however see the issue if I upgrade your test case to the latest versions of jQuery / jQuery UI: http://jsfiddle.net/tj_vantoll/KguV5/show. Are you seeing the issue there?

comment:12 Changed 6 years ago by mgahlot

Status: pendingnew

Hi,

Yes, On IE8 & IE9, the default tooltip appears occasionally but I am seeing it on every 2nd or 3rd mouse hovering on button.

I checked the above link & again it is working fine in Chrome but not on IE8.

Find the below link for snapshot. https://dl.dropboxusercontent.com/u/110099535/HTML/image.png

comment:13 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #8746.
Ok I can recreate this now with a really basic test case: http://jsfiddle.net/tj_vantoll/p2CJK/. It happens in IE7 - 9 which is consistent with #8746 so I'm closing this one as a duplicate.

Thanks for your test case and help on this @mgahlot.

comment:14 Changed 6 years ago by mgahlot

I would like to see this issue as fixed in upcoming release of jQuery UI.

Your Welcome...:)

Note: See TracTickets for help on using tickets.