Opened 7 years ago

Closed 7 years ago

#8810 closed bug (duplicate)

Sortable Position Not Calculating Correctly

Reported by: arpowers Owned by: arpowers
Priority: minor Milestone: 1.10.0
Component: ui.sortable Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

I appears that an attempt was made to make sortables calculate their position better.

This commit: https://github.com/jquery/jquery-ui/commit/bae06d2b1ef6bbc946dce9fae91f68cc41abccda#commitcomment-2141597

Unfortunately, it appears that this new calc system does not work at all for large draggables. Often the calculated 'drop spot' is off screen and this commit renders the plugin useless.

I recommend a reversion to the previous code until an option or more versatile system can be implemented.

A couple 20 second vids to further explain:

This is how its supposed to work: http://screencast.com/t/ZPHr5MW5YQ

This is how it works with the new methodology (it doesn't!) http://screencast.com/t/EbshygSNXmY

Change History (5)

comment:1 Changed 7 years ago by mikesherov

Thanks! Can you please provide a fiddle as well!

comment:2 Changed 7 years ago by tj.vantoll

Owner: set to arpowers
Status: newpending

@arpowers You can use http://jsfiddle.net/ZgAqH/ to get started. Open the link and click to "Fork" (in the top menu) to get started.

Note also that #8792 was reported as a regression caused by the referenced commit.

comment:3 Changed 7 years ago by arpowers

Status: pendingnew

Alright, took me a minute but I got it duped.

Here is the JS fiddle: http://jsfiddle.net/arpowers/a7rxv/1/

Seems similar to the problem mentioned in the regression.

Last edited 7 years ago by arpowers (previous) (diff)

comment:4 Changed 7 years ago by arpowers

I can verify that it is the nested elements that are also floated ...

comment:5 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #8792.
@arpowers Thanks for taking the time to make the test case. This indeed looks like the same problem as #8792 so I'm going to close this one as a duplicate.

Note: See TracTickets for help on using tickets.