Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#8792 closed bug (fixed)

Sortable: Issue with floated items in connected lists

Reported by: BlazeCell Owned by: mikesherov
Priority: minor Milestone: 1.10.2
Component: ui.sortable Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

The latest version of Sortable breaks when sorting floated items. It will only allow items to to be placed on the last row of a container.

Change History (21)

comment:1 Changed 7 years ago by BlazeCell

Sortable: Reverted a line back to 1.8.24 version. Fixed #8792 - Sortable on floating items only allows items to be placed on the last row

The following github pull request has the fix: https://github.com/jquery/jquery-ui/pull/818

comment:2 Changed 7 years ago by tj.vantoll

Owner: set to BlazeCell
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the git version of both jQuery UI and jQuery to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/ZgAqH/ Open the link and click to "Fork" (in the top menu) to get started.

Also the line that you're reverting (https://github.com/jquery/jquery-ui/commit/bae06d2b) was part of a change to fix #8572, #8573, and #8574.

comment:3 Changed 7 years ago by BlazeCell

Status: pendingnew

Additionally, be sure to test against the git version of both jQuery UI and jQuery to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/ZgAqH/ Open the link and click to "Fork" (in the top menu) to get started.

Thanks for the jsfiddle boilerplate, that helps to get things up and running quickly. =)

I've put together a jsfiddle with the same code I've performed my internal tests with: http://jsfiddle.net/BlazeCell/QkUft/8/

You can see the issue when you try to sort any of the items. The placeholder indicates that the sort action will drop the item on the last row, regardless of which sortable container you hover your mouse over. And when you release the mouse, the item will indeed be sorted to the bottom row.

comment:4 Changed 7 years ago by tj.vantoll

Keywords: haspatch added
Status: newopen
Summary: Sortable on floating items only allows items to be placed on the last row.Sortable: Issue with floated items in connected lists

Minified this one down a little more - http://jsfiddle.net/tj_vantoll/rRDba/. I can confirm the issue in 1.9.1 and that it functions fine in 1.8.24. The issue only occurs when the connectWith option is set and the items are floated.

comment:5 Changed 7 years ago by tj.vantoll

#8810 is possibly related to this.

comment:6 Changed 7 years ago by arpowers

I can verify that #8810 is probably the same bug.

Another JSFiddle with the issue: http://jsfiddle.net/arpowers/a7rxv/1/

Last edited 7 years ago by arpowers (previous) (diff)

comment:7 Changed 7 years ago by tj.vantoll

#8810 is a duplicate of this ticket.

comment:8 Changed 7 years ago by mikesherov

Keywords: haspatch removed
Owner: changed from BlazeCell to mikesherov
Status: openassigned

comment:9 Changed 7 years ago by tj.vantoll

#8909 is a duplicate of this ticket.

comment:10 Changed 7 years ago by tj.vantoll

#8936 is a duplicate of this ticket.

comment:11 Changed 7 years ago by arpowers

Is there any update on the fix for this?

comment:12 Changed 7 years ago by tj.vantoll

Milestone: 1.10.0none

comment:13 Changed 7 years ago by tj.vantoll

Possible duplicate: #9041.

comment:14 Changed 7 years ago by tj.vantoll

#9070 is a duplicate of this ticket.

comment:15 Changed 7 years ago by tj.vantoll

comment:16 Changed 7 years ago by zhizhangchen

I've sent a pull request to fix this problem: https://github.com/jquery/jquery-ui/pull/916

comment:17 Changed 7 years ago by tj.vantoll

#9099 is a duplicate of this ticket.

comment:18 Changed 7 years ago by tj.vantoll

We should check whether the fix addresses #7045 & #7501 as they are similar issues.

comment:19 Changed 6 years ago by tj.vantoll

#9124 is a duplicate of this ticket.

comment:20 Changed 6 years ago by John Chen

Resolution: fixed
Status: assignedclosed

Sortable: Skip items that are not at the same line as the cursor when floating. Fixes #8792: Issue with floated items in connected lists.

Changeset: 89473f6557662d905a63faa3ae3520bf3715a7e8

comment:21 Changed 6 years ago by mikesherov

Milestone: none1.10.2
Note: See TracTickets for help on using tickets.