Opened 7 years ago

Closed 7 years ago

#8822 closed bug (duplicate)

Track should not be lost without a mouseleave

Reported by: Jidewe Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.tooltip Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hello,

I have an issue with mouse tracked tooltips and tables.

Here is a jsfiddle : http://jsfiddle.net/6Q95u/

I have a tooltips on TR tags, and when I roll over one of the line, the toltips appears and follow the mouse until I jump to another TD on the same line. Then the track is stopped and the tooltips stay in his determined position, like when the tracking option is set to false. I've quickly checked the code. It seems to use focus to catch the mouse movement. But when you move your mouse in a table over a border, the focus of TR tag is lost and you trigger a mouseout. It is not the case with a mouseleave.

If, for some reason, we can't use mouseleave, the widget should at least react and reset his tracking of the mouse.

I guess this bug can happen with other nested element than table. I haven't tested more.

Change History (1)

comment:1 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #8799.

Note: See TracTickets for help on using tickets.