Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8799 closed bug (fixed)

Tooltip: tracking fails on nested elements

Reported by: acouch Owned by:
Priority: minor Milestone: 1.9.2
Component: ui.tooltip Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

When the element with a tracking tooltip has child elements, the tracking breaks when the mouse moves between the parent and children.

Fiddle: http://jsfiddle.net/5jwhR/

Steps to reproduce:

  • hover over the parent element
  • move mouse to hover over child element

OR

  • hover over child element
  • move mouse to hover over parent element

Originally reported by shnitz on #8644

Well that is not really good. Oh well. I ended up just not tracking and using the show delay. The tracking had another issue that prevented it from working with my markup anyway. ( http://jsfiddle.net/w3QT7/) if your interested, I sometimes feel like I'm doing everything the hard way :)

Change History (5)

comment:1 Changed 7 years ago by tj.vantoll

Status: newopen

comment:2 Changed 7 years ago by Scott González

Resolution: fixed
Status: openclosed

Tooltip: Removed logic for handling tracking tooltips which gain focus while open (we no longer mix events). Fixes #8799 - Tooltip: tracking fails on nested elements.

Changeset: ca0df6b9007a13dabdf7e78acb3d30bdb0928a97

comment:3 Changed 7 years ago by Scott González

Tooltip: Removed logic for handling tracking tooltips which gain focus while open (we no longer mix events). Fixes #8799 - Tooltip: tracking fails on nested elements. (cherry picked from commit ca0df6b9007a13dabdf7e78acb3d30bdb0928a97)

Changeset: 0be0c2603c8289027ce93a1daa38c8599c639b54

comment:4 Changed 7 years ago by Scott González

Milestone: 1.10.01.9.2

comment:5 Changed 7 years ago by Scott González

#8822 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.